# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<Semantic>(?<Major>[0-9]+)\.(?<Minor>[0-9]+)(?:\.(?=[0-9]))?(?<Maintenance>[0-9]+)?(?:\.(?=[0-9]))?(?<Patch>[0-9]+)?)(?<Label>(?:(?:\.|\-|\+)?\w+)+)?"
test_str = ("Should Match:\n"
"5.6.20.4-dev+a2c4ok ok\n"
"1.3.2\n"
"12.0.2.1000 ok\n"
"3.60.2.300 ok\n"
"0.0.2.1-dev ok\n"
"2.0.3.1dev ok\n"
"this is v1.2.3.1 ok\n"
"1.2.3\n"
"30.0000.1.222.3333\n"
"Should Not Match\n"
"1\n"
"1.\n"
"12\n"
"12.\n"
"123\n"
"123.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.