const regex = /(?<!\[)(www\.)?\w*[.][a-z]{2,5}(?!\])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\[)(www\\.)?\\w*[.][a-z]{2,5}(?!\\])', 'gm')
const str = `Der Text soll verdeutlichen, wie der reguläre Ausdruck für www.google.de funktioniert, aber auch für google.de muss es klappen. Aber auch für (www.google.de). Sowie für http://www.google.de. Auch für [google.de falaffel]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}