$re = '/(?<!\[)(www\.)?\w*[.][a-z]{2,5}(?!\])/m';
$str = 'Der Text soll verdeutlichen, wie der reguläre Ausdruck für www.google.de funktioniert, aber auch für google.de muss es klappen. Aber auch für (www.google.de). Sowie für http://www.google.de. Auch für [google.de falaffel]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);