import Foundation
let pattern = #"(?<!\[)(www\.)?\w*[.][a-z]{2,5}(?!\])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Der Text soll verdeutlichen, wie der reguläre Ausdruck für www.google.de funktioniert, aber auch für google.de muss es klappen. Aber auch für (www.google.de). Sowie für http://www.google.de. Auch für [google.de falaffel]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)