use strict;
my $str = '// comments at the beginning of the file are removed
/*
Block comments are removed - easy peasy
*/
https://urls.are.preserved.for.you// and comments after them are removed
asdfasdf// the comment can bump right up to text
asdfasdf;// ...or a semicolon.
{
foo:// you will need a parser to remove this comment b/c it smells like a URL
"bar",// ...but not this one
boo: // ...or this one
"who"
}';
my $regex = qr/(?<!:)(\/\/).+$|\/\*[\s\S]+\*\//mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}