using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"time\(.*\)=(\d*(?:\.\d*)?)s";
        string input = @"    time(c:\Program Files\10.0\2\c1xx.exe)=0.23609s < 377648803844 - 377654889334 >
    time(c:\Program Files\10.0\2\c1xx.exe)=004421.s < 377648803844 - 377654889334 >
";
        RegexOptions options = RegexOptions.Multiline;
        
        foreach (Match m in Regex.Matches(input, pattern, options))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}