import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*time)[^.]*$";
final String string = "testtime -> not allowed\n"
+ "tim etest -> allowed\n"
+ ".\n"
+ "thetimetest -> not allowed\n"
+ ".\n"
+ "the time test -> not allowed\n"
+ "test.my -> not allowed\n"
+ "my.testtime -> not allowed";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}