import re
regex = re.compile(r"<a(?:.*\>)(.*)<\/a>", flags=re.IGNORECASE)
test_str = ("<a>I don't want this</a>\n"
"startString\n"
"test1\n"
"<a>I want this1</a>\n"
"test2\n"
"<a>I want this2</a>\n"
"endString\n"
"gibberish\n"
"<a>I don't want this</a>\n"
"startString\n"
"test1\n"
"<a>I want this3</a>\n"
"test2\n"
"<a>I want this4</a>\n"
"endString\n"
"gibberish\n"
"<a>I don't want this</a>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")