#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\<(ol)(?: .*?)?\>(?:[^\<]|\<(.*?)\>.*\<\/\2\>)*\<\/\1\>"
Local $sString = "<ol>kjkjkj" & @CRLF & _
"" & @CRLF & _
"</ol>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<ol s>" & @CRLF & _
" <li>Table of Contents.....................CT.TS</li>" & @CRLF & _
" <li>Gamecube Controls.....................CN.GC</li>" & @CRLF & _
" <li>Nintendo 64 Controls..................CN.64</li>" & @CRLF & _
" <li>Walkthrough...........................01.00" & @CRLF & _
" <ol>" & @CRLF & _
" <li>Kokiri Forest...............01.01</li>" & @CRLF & _
" </ol>" & @CRLF & _
" </li> " & @CRLF & _
" <li>Sidequests & Minigames................02.00" & @CRLF & _
" <ol>" & @CRLF & _
" <li>Shooting Gallery............02.01</li>" & @CRLF & _
" </ol>" & @CRLF & _
" </li>" & @CRLF & _
" <li>Boss Guide............................03.00" & @CRLF & _
" <ol>" & @CRLF & _
" <li>Gohma.......................03.01</li>" & @CRLF & _
" <li>Final Boss [Second Form]....03.15</li>" & @CRLF & _
" </ol>" & @CRLF & _
" </li>" & @CRLF & _
" <li>Item Checklist........................04.00" & @CRLF & _
" <ol>" & @CRLF & _
" <li>Final Dungeon...............04.47</li>" & @CRLF & _
" </ol>" & @CRLF & _
" </li>" & @CRLF & _
" <li>Shop Inventory........................05.00 " & @CRLF & _
" <ol>" & @CRLF & _
" <li>Kokiri Shop [Young].........05.01</li>" & @CRLF & _
" <li>Goron Shop [Adult]..........05.09</li>" & @CRLF & _
" </ol>" & @CRLF & _
" </li>" & @CRLF & _
" <li>Ocarina Notes.........................06.00" & @CRLF & _
" <ol><ol>sdsds</ol>" & @CRLF & _
" <li>Requ<ol></ol>iem of Spirit...........06.12</li>" & @CRLF & _
" </ol>" & @CRLF & _
" </li>" & @CRLF & _
" <li>Heart Containers......................07.00</li>" & @CRLF & _
" <li>Item List.............................15.00</li>" & @CRLF & _
" <li>Legal & Copyright.....................LE.AL</li>" & @CRLF & _
" <li>Credits & Thanks......................CR.DS</li>" & @CRLF & _
" </ol>" & @CRLF & _
"" & @CRLF & _
"<ol><ol><ol><ol><ol></ol></ol></ol></ol></ol>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"sdsd" & @CRLF & _
"k<ol>jlkjlkj " & @CRLF & _
"kjbkjh</ol> "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")