re = /img src="(.*?)"/
str = '<img src="/sites/ContentCenter/Graphics/map-al.jpg" alt="map al" style="width:611px;height:262px;" /> <br></p><p><br></p><p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end