// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"img src="(.*?)""#).unwrap();
let string = "<img src=\"/sites/ContentCenter/Graphics/map-al.jpg\" alt=\"map al\" style=\"width:611px;height:262px;\" /> <br></p><p><br></p><p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}