// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?<S>((?<W>[^\x20\.\r\n\(\)]*)\x20)*\g<W>\.|\(\g<W>((\x20\g<W>)*)?\))(\x20\g<S>)*)?$").unwrap();
let string = "Este é o meu texto. Eu sou lindo e irresistível. (Versão portuguesa)
This is my text. I'm beautiful and irresistible. (English version)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}