use strict;
my $str = '<a href="http://www.testassociation.com/test.html?ab=5&cd=5&ab=c" target="_blank">Customer Association</a>&';
my $regex = qr/(?!&|<)&/p;
my $subst = '&';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";