$re = '/^(?!.*\b([a-z]{2})\b.*\b\1\b)(fr|sa|su|mo|tu|we|th)?(?:,(?:fr|sa|su|mo|tu|we|th)){0,5}$/m';
$str = 'MATCH
fr
mo
fr,sa
fr,tu
su,mo,tu,we,fr,sa
NO MATCH
fr,fr,fr,fr
sa,sa,sa,sa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);