use strict;
my $str = 'I want to delete numbers like 84 but not dates like 2015';
my $regex = qr/\b(?!(?:18|19|20)\d{2}\b)\d+\b/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";