re = /\b(?!(?:18|19|20)\d{2}\b)\d+\b/
str = 'I want to delete numbers like 84 but not dates like 2015'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result