import Foundation
let pattern = #"\b(?!(?:18|19|20)\d{2}\b)\d+\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"I want to delete numbers like 84 but not dates like 2015"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}