#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^ --start" & @CRLF & _
"(1?[\-\.\_]?) question mark makes the block or single character before it optional" & @CRLF & _
"([0-9]{3})" & @CRLF & _
"(-?)" & @CRLF & _
"([0-9]{4})" & @CRLF & _
"$"
Local $sString = "" & @CRLF & _
"1." & @CRLF & _
"555." & @CRLF & _
"555-" & @CRLF & _
"1212" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")