package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^ --start
(1?[\-\.\_]?) question mark makes the block or single character before it optional
([0-9]{3})
(-?)
([0-9]{4})
$`)
var str = `
1.
555.
555-
1212
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}