re = /Need to process image tag.*\?custId=(\d+)/m
str = 'Need to process image tag <img src=\\"http://danny.oz.au/p/56214815-tripod.jpg?custId=1235\\"/>
Need to process image tag <img src=\\"http://danny.oz.au/p/56214815-tripod.jpg?custId=123445\\"/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end