#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<div class="cats">|<div.*?<\/div>|(cat)(?=.*?<\/div>)"
Local $sString = "cat" & @CRLF & _
"<div class="cats">black cat, white cat</div>" & @CRLF & _
"cat" & @CRLF & _
"<div class="dogs">black cat, white cat</div>" & @CRLF & _
"cat" & @CRLF & _
"<div class="cats">black" & @CRLF & _
" cat, white cat</div>" & @CRLF & _
"cat" & @CRLF & _
"<div class="cats">black cat, white cat"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")