$re = '/<div class="cats">|<div.*?<\/div>|(cat)(?=.*?<\/div>)/m';
$str = 'cat
<div class="cats">black cat, white cat</div>
cat
<div class="dogs">black cat, white cat</div>
cat
<div class="cats">black
cat, white cat</div>
cat
<div class="cats">black cat, white cat';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);