re = /^[^\s()]+(?:\([^()]*\))?$/m
str = 'I-IVWM_Ask-21_(max_2h)
D-7849_DG303_(max_4h)
Aliante_Privato'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end