$re = '/(\b\w+\b)(?=.*\b\1\b)/m';
$str = 'I want to eat apple. apple is a fruit
I want to eat apple. apple is a fruit want ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);