#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\|\|\K(\d+)(?=\|\|[\s\S]+#\1(\d+))|(?:\r?\n#.*)+$"
Local $sString = "||0011||" & @CRLF & _
"||0011||" & @CRLF & _
"||0011||" & @CRLF & _
"||0011||" & @CRLF & _
"||0011||" & @CRLF & _
"||0011||" & @CRLF & _
"||0011||" & @CRLF & _
"||0011||" & @CRLF & _
"||0011||" & @CRLF & _
"||0122||" & @CRLF & _
"||0122||" & @CRLF & _
"||0122||" & @CRLF & _
"||0122||" & @CRLF & _
"||0122||" & @CRLF & _
"||0122||" & @CRLF & _
"||0122||" & @CRLF & _
"||0122||" & @CRLF & _
"||0122||" & @CRLF & _
"||0122||" & @CRLF & _
"||0232||" & @CRLF & _
"||0232||" & @CRLF & _
"||0232||" & @CRLF & _
"||0232||" & @CRLF & _
"||0232||" & @CRLF & _
"||0232||" & @CRLF & _
"||0232||" & @CRLF & _
"||0232||" & @CRLF & _
"||0232||" & @CRLF & _
"||0232||" & @CRLF & _
"||0232||" & @CRLF & _
"#001112" & @CRLF & _
"#012234" & @CRLF & _
"#023213"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)