const regex = /\|\|\K(\d+)(?=\|\|[\s\S]+#\1(\d+))|(?:\r?\n#.*)+$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\|\\|\\K(\\d+)(?=\\|\\|[\\s\\S]+#\\1(\\d+))|(?:\\r?\\n#.*)+$', 'g')
const str = `||0011||
||0011||
||0011||
||0011||
||0011||
||0011||
||0011||
||0011||
||0011||
||0122||
||0122||
||0122||
||0122||
||0122||
||0122||
||0122||
||0122||
||0122||
||0122||
||0232||
||0232||
||0232||
||0232||
||0232||
||0232||
||0232||
||0232||
||0232||
||0232||
||0232||
#001112
#012234
#023213`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);