use strict;
my $str = '||0011||
||0011||
||0011||
||0011||
||0011||
||0011||
||0011||
||0011||
||0011||
||0122||
||0122||
||0122||
||0122||
||0122||
||0122||
||0122||
||0122||
||0122||
||0122||
||0232||
||0232||
||0232||
||0232||
||0232||
||0232||
||0232||
||0232||
||0232||
||0232||
||0232||
#001112
#012234
#023213';
my $regex = qr/\|\|\K(\d+)(?=\|\|[\s\S]+#\1(\d+))|(?:\r?\n#.*)+$/p;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";