#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)([^a-z0-9\)\];\-_]*\{)"
Local $sString = "a {" & @CRLF & _
"color:black;" & @CRLF & _
"background-color:blue;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"{color:red}" & @CRLF & _
"<!-- TEST -->" & @CRLF & _
"" & @CRLF & _
"@media screen and (max-width:620px) {" & @CRLF & _
"/* TEST 2 */" & @CRLF & _
"a.test {color:blue;}" & @CRLF & _
"p[class="test2"] {color:green;}" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")