$re = '/{((?:[^{}]++|(?R))*)}/x';
$str = 'abc {get me {!but not me!}} def {and get {!but not me again!} me} ghi';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);