re = /(?!changelogs)(\d+)/mi
str = 'http://www.opera.com/docs/changelogs/unified/1215/
http://www.opera.com/security/advisory/1047
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end