import re
regex = re.compile(r"^<!--(?!\[[^]+])(?:(?!-->).)*-->$", flags=re.DOTALL | re.MULTILINE)
test_str = ("<!-- some comments 1 -->\n"
"<!-- 1.91 -->\n"
"<!--\n"
"//-->\n"
"<!-- -->\n\n"
"<!--[if IE]> <![endif]-->\n"
"<!--[if !IE]><!--> <!--<![endif]-->\n"
"<!--[if IE 6]> <![endif]-->\n\n"
"<!--[if lte IE 6]><html class=\"ie6 no-js\">\n"
"<!--[if gt IE 8]><!--><html class=\"no-js\"><!--<![endif]-->\n"
"<!--[if IE]>\n"
"<meta http-equiv=\"X-UA-Compatible\" content=\"IE=edge,chrome=1\">\n"
"<![endif]-->")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")