# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\D*\d+\K.*//gm;t' <<< "Hubert 208 apt 1
Mass Av 300, block 3"