use strict;
my $str = 'Hubert 208 apt 1
Mass Av 300, block 3';
my $regex = qr/^\D*\d+\K.*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";