package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)M[^*]+\*`)
var str = `MEALYRAQVLVDLT*MQLPSSFAALAAQFDQL*EKEKF*SLIARSLHRPQ**LLMFSLLVASVFTPCSALPFWSIKFTLFILS*SFLISDSILFIRVIDQEIKYVVPL*DLK*LTPDYCKCD*`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}