$re = '/\|(\w+)\|/';
$str = 'This is a [#TEST#] of the |regular| expression to get |matches|';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);