re = /<a href="(?!https?:\/\/)[^"]+">(.*?)<\/a>/
str = 'This string contains a <a href="/local/link.html">local link</a> and a <a href="http://remo.te/link.com">remote link</a>'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result