# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"oz(3[4-9]|[4-9][0-9]|[1-9][0-9]{2}|[12][0-9]{3}|3[0-8][0-9]{2}|39[0-7][0-9]|398[0-2])"
test_str = "oz31 oz32 oz33 oz34 oz35 oz55 oz100 oz123 oz999 oz1000 oz2000 oz3000 oz3981 oz3982 oz3983"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.