using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?(404|410))\/\d+$";
string input = @"http://www.agencedevoyage.com/voyage/ameriques/etats-unis/2/";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}