# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b((?:a1|a2|a3|a4)\*)(?=\b(?:a1|a2|a3|a4)\b)|\*/\1/g;t' <<< "3*a1 + a1*a2 + 4*a3*a4 + a1*a3"