use strict;
my $str = '3*a1 + a1*a2 + 4*a3*a4 + a1*a3';
my $regex = qr/\b((?:a1|a2|a3|a4)\*)(?=\b(?:a1|a2|a3|a4)\b)|\*/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";