const regex = /(?<!^)"(?!$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!^)"(?!$)', 'gm')
const str = `Stage 2:
field
"another "field""
""another" field"
"fie|ld"`;
const subst = `""`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);