$re = '/(?<!^)"(?!$)/m';
$str = 'Stage 2:
field
"another "field""
""another" field"
"fie|ld"';
$subst = "\"\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;