using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<[pP]>)?(?:<strong>)(?:<br \/>)([""!?–\-\/\wÅåÄäÖö;,.\(\)\[\]&\s:+]+)(?:<\/strong>)([""!?–\-\/\wÅåÄäÖö;,.\(\)\[\]&\s:+]+)((?:<br \/>)?)([""!?–\-\/\wÅåÄäÖö;,.\(\)\[\]&\s:+]+)";
string substitution = @"<p><strong>$1</strong>$2$3$4</p>";
string input = @"<strong><A NAME=""Bondeupproret""></A>Andersson, Per,</strong> Bondeupproret i Skåne 1811 / Per Andersson, Arne Ribnell. – [Ny, utökad uppl.]. – Malmö, 1996. – 12 s.
<p><strong><br />Andersson, Per,</strong> Litteratur om Svedalatrakten. – Malmö[?], 197-. – 6 bl.
<p><strong><br /><A NAME=""borgar_slott""></A>Andersson, Per,</strong> Skånska borgar, slott och herrgårdar. – Lund, 1996. – 212 s.
<p><strong><br /><A NAME=""Skånska_kyrkor""></A>Andersson, Per,</strong> Skånska kyrkor, kapell, kloster och andra kyrkliga byggnader. – Malmö, 1985. – 254 s.
<p><strong><br /><A NAME=""Att_läsa""></A>Ericsson, Acke,</strong> Att läsa om Sturup. // SkNK. – 1973, h. 1, s. 37-40.
<br />Urval ur Acke Ericssons bibliografi, se nedan.
<p><strong><br /><A NAME=""Sturup""></A>Ericsson, Acke,</strong> Sturup. – Malmö, 1973. – 24 bl.
<p><strong><br />Jönsson, Knut,</strong> Anteckningar till en bibliografi över Bara kommun. – Borås, 1975. – 76 bl.
<p><strong><br />Lönnäng, Ragnar</strong>, Handbok för resor till skånska slott. - Simrishamn, 2003 – 156 s. : ill.
<br />Börringekloster, Klågerup, Skabersjö, Torup.
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}