re = /^(\d+).*credits between.*?(\d+)$/
str = '04 credits between subjects of block 02'
# Print the match result
str.match(re) do |match|
puts match.to_s
end