import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\#|\\/\\/)[^\\n\\r]*(?<![\\?>])";
final String string = "<!--- sdsdsdsdsds --->\n\n"
+ "<!--- sdsdsdsdsds --->\n\n"
+ "<!--- sdsdsdsdsds --->\n\n"
+ "<!--- sdsdsdsdsds --->\n\n"
+ "/*asdasd asdasd asdasd\n"
+ "asdasd asdasd asdasds?sdsd*/\n\n"
+ " /*echo'<div class=\"a\" id=\"a\">Content for class \"a\" id \"a\" Goes Here</div>';*/ \n\n"
+ "//sdsdsdsddsdsd\n\n"
+ "#sdsdsds?sdsd\n\n"
+ "<?php #echo'<div class=\"a\" id=\"a\">Content for class \"a\" id \"a\" Goes Here</div>'; ?> ?>\n\n"
+ "<?php //echo'<div class=\"a\" id=\"a\">Content for class \"a\" id \"a\" Goes Here</div>'; ?> ?>\n\n"
+ "<?php /*echo'<div class=\"a\" id=\"a\">Content for class \"a\" id \"a\" Goes Here</div>';*/ ?>\n\n"
+ "<?php /*?><?php echo'<div class=\"a\" id=\"a\">Content for class \"a\" id \"a\" Goes Here</div>'; ?><?php */?>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}