using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+) ?(kg|ml|gallon)(?:.*(water|oil))?";
string input = @"1 kg of water
20 ml water
1 gallon of crude oil
1 kg of diesel
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}