$re = '/^(?!.*\b(\d+)\b.*\b\1\b)\d+(?:,\d+)+$/m';
$str = '1,2,13
1,14,22,3
1,12,12,3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);