$re = '/^(?i:(?:[a-z]{3,10}\s+(?:\w{3,7}?:\/\/[\w\-\.\/]*(?::\d+)?)?\/[^?#]*(?:\?[^#\s]*)?(?:#[\S]*)?|connect (?:\d{1,3}\.){3}\d{1,3}\.?(?::\d+)?|options \*)\s+[\w\.\/]+|get \/[^?#]*(?:\?[^#\s]*)?(?:#[\S]*)?)$/m';
$str = 'GET /sale/kenwood-kac-6402-by-download-mauritron-221328-264064/ HTTP/2.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);