import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "SELECT \\* FROM (`)?\\w+\\1 WHERE .*";
final String string = "SELECT * FROM `commands` WHERE `UID` LIKE '70f8b955-fe64-4efe-8976-737c77c12c4b' AND `InsertTime` > '1464091507' OR `UID` LIKE \"\" AND `InsertTime` > '1464091507'$checkin:5000;#";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}