re = /:\\(\S*)\\/i
str = 'c:\\foo\\bar\\baz.txt
C:\\FOO\\BAR\\BAZ.TXT
C:\\FoO\\BaR\\BaZ.TxT
C:\\FoO\\BaZ.TxT
C:\\BaZ.TxT'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end